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ABSTRACT: We present an interactive, Web-based application that provides a comfortable access

to evaluating, comparing, and plotting of a multitude of different plasma and atomic physics pa-

rameters, grouped by the unit dimensions. A special attention is devoted to the Stark broadening

which is calculated with a good accuracy for transitions between degenerate atomic levels. The

list of the entities calculated encompasses over one hundred entries and is easily expandable. The

application is built using open-source components and is compatible with a majority of modern

browsers.
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1 Introduction

Plasma physics is a rapidly developing discipline integrating practically all subjects of modern fun-

damental and applied physics, including electrodynamics, kinetic theory, and atomic, molecular,

and optical physics. There are many excellent texts devoted to different subjects of plasma physics,

however, because of the vastness of material, it is hardly possible to address all of it under a single

textbook cover. Furthermore, thorough studies focused on a specific matter may unintentionally

make finding a simple general (even though not highly accurate) estimation difficult for a casual

reader. Filling in the gap are compilations of formulae from different fields of plasma physics,

allowing for calculations of a multitude of relevant entities using straightforward numerical ex-

pressions. One such a compilation is the venerable NRL Plasma Formulary by J.D. Huba [1],

originally inspired by D.L. Book. Handbooks by A. Anders [2] and D.A. Diver [3] are providing

more extensive coverage, each at a somewhat different perspective.

The purpose of the present work is to extend usability of the existing plasma formularies. To

this end, a Web-based computer application was designed that allows for (i) calculating miscel-

laneous plasma physics entities in an interactive manner, (ii) comparing several pre-selected ones

(having, evidently, the same dimensionality), and (iii) plotting resulting values as a function of

one of the plasma parameters, e.g., the electron density. The application is built using open-source

components and is itself released under the GNU General Public License [4] terms. Furthermore,

each entity is linked to the corresponding on-line Wikipedia [5] article, thus encouraging practi-

tioners in the fields of atomic and plasma physics to check, revise, and contribute in other ways to

the world-largest free encyclopedia.
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2 Models and assumptions

In the calculations, the following models are employed. The plasma is assumed to consist of

electrons (e) and two heavy atomic species, ions (i) and radiators (r). The latter are representative

of frequent cases when a tracer element, differing from the majority ions in the plasma by mass

and/or charge, is used for spectroscopic diagnostics. Each of the species s, s = {e, i, r} may have

different temperature Ts. The masses ms and charges qs of the heavy species s= {i, r} are expressed
in units of the proton mass mp and elementary charge e, respectively:

ms = Msmp , (2.1)

qs = Zse . (2.2)

The density of the radiator species Nr in the plasma is determined by its fraction 0≤ Pr ≤ 1 relative

to the total density of the heavy species:

Pr = Nr/(Ni +Nr) . (2.3)

Using the quasi-neutrality condition

Ne = ZiNi +ZrNr , (2.4)

the ion and radiator densities are calculated as

Ni =
1−Pr

Zi(1−Pr)+ZrPr
Ne (2.5)

and

Nr =
Pr

Zi(1−Pr)+ZrPr
Ne , (2.6)

respectively. All plasma particles are non-relativistic, i.e.,

kBTs ≪ msc
2 , (2.7)

where kB is the Boltzmann constant and c is the speed of light.

The radiators are assumed to be hydrogen-like, i.e., a non-relativistic atom with a single elec-

tron above a core with

Zcore = Zr +1. (2.8)

The radiative transition of interest is defined by the upper nu and lower nℓ principal quantum

numbers.

A macroscopic magnetic field B is assumed to be homogeneous in space and constant in time.

3 Formulary

3.1 Atomic units

All calculations are performed internally using the atomic units (a.u.), i.e., the electron mass me,

the elementary charge e, the reduced Plank constant h̄, and the Coulomb constant 1/(4πε0) are all

assumed unity. Furthermore, the Boltzmann constant kB is also assumed unity, thus, temperature is

represented in energy units. We note that in the a.u. the speed of light c is equal to the reciprocal

value of the fine-structure constant α ≈ 1/137.
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3.2 Basic entities

In the following equations, the s index stands for species and assumes, according to the model,

values of e (electrons), i (ions) or r (radiators).

A typical inter-particle distance (Wigner-Seitz radius):

rs = 3

√

3

4πNs

. (3.1)

Mass density:

ρs = msNs . (3.2)

Total mass density:

ρtot = ∑
s

ρs . (3.3)

Debye length:

λD,s =

√

Ts

4πNsqs2
. (3.4)

Full Debye length (screening by all plasma species not heavier than a given one):

λ̄D,s =

(

∑
m′

s≤ms

λ−1
D,s′

)−1

. (3.5)

Coupling parameter:

Γs =
q2s
rsTs

=
1

3

(

rs

λD,s

)2

. (3.6)

Pressure (an ideal gas):

ps = NsTs . (3.7)

Total gas dynamics pressure:

ptot = ∑
s

ps . (3.8)

Magnetic-field pressure:

pB =
B2

8π
. (3.9)

Beta parameter:

β =
ptot

pB
. (3.10)

Thermal velocity:

vth,s =
√

Ts/ms . (3.11)

Gyrofrequency:

ωg,s = 2π fg,s =
qsB

msc
. (3.12)

Gyroradius:

rg,s =
vth,s

ωg,s
. (3.13)

– 3 –



2
0
1
1
 
J
I
N
S
T
 
6
 
P
1
0
0
0
9

Classical distance of minimum approach:

rm,s = q2s/Ts . (3.14)

Thermal de Broglie wavelength:

Żs =

√

2π

msTs
. (3.15)

Fermi energy of an ideal electron gas:

EF =
1

2

(

3π2Ne

)2/3
. (3.16)

Chemical potential of an ideal electron gas:

µe = EF ζ (Te/EF) , (3.17)

where the reduced Fermi-Dirac chemical potential ζ is approximately calculated as

ζ (t) ≈







1− πt
12
− (πt)2

80
t < 0.3

t
[

ln 4
3
√

πt3/2
+

√
2

3
√

πt3/2
+ · · ·

]

t ≥ 0.3
. (3.18)

Here, the high-t expansion in powers of t−3/2 continues up to the ∼ 1/t6 term [6],1 providing a

better-than-1% accuracy.

Chemical potential of an ideal classical gas (used for the heavy plasma particles, i.e., for ions and

radiators, s = {i, r}):
µs = Ts ln(NsŻ

3
s ) . (3.19)

3.3 Waves

Plasma frequency:

ωp,s = 2π fp,s =

√

4πNsq2s
ms

. (3.20)

Plasmon energy:

Ep = ωp,e . (3.21)

Inertial length:

λi,s = c/ωp,s . (3.22)

Alfvén velocity:

vA =

(

∑
qs 6=0

√
4πmsNs

B

)−1

. (3.23)

1Note that the leading “+” in the unnumbered expression following eq. (3) should be replaced with “t”.
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3.4 Collisions

Thomson cross-section:

σT,s =
8π

3
r20,s , (3.24)

where r0,s is the classical electromagnetic radius:

r0,s =
α2q2s
ms

. (3.25)

Coulomb logarithm of species s scattered off species s′:

λs|s′ = ln
bmax

bmin
, (3.26)

where

bmax = λ̄D,s + λ̄D,s′ (3.27)

and

bmin =
2 |qsqs′ |(ms +ms′)

3msms′(vth,s + vth,s′)
2

. (3.28)

Thermal relaxation rate of species s due to collisions with species s′:

νs|s′ =
8
√
2πq2sq

2
s′ns′λs|s′

3msms′

(

v2th,s + v2th,s′

)3/2
. (3.29)

Dreicer field:

FD =
4πNeλe|e

Te
. (3.30)

3.5 Spectroscopy

Transition energy:

Etr = Eu−Eℓ , (3.31)

where Eu are Eℓ bound energies of the upper and lower levels, respectively, calculated accounting

for isotopic shift:

Ei =
Z2
core

2n2i (1+1/mr)
. (3.32)

Transition frequency:

ωtr = 2π ftr = Etr . (3.33)

Transition wavelength:

λtr = c/ ftr . (3.34)

Minimal energy distance (distance to the nearest energy level):

|Enu −Enu+1| . (3.35)
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Transition oscillator strength for absorption is calculated exactly for the Lyman series (nℓ = 1) and

approximately using the quasi-classical Kramers formula with the Gaunt-factor correction g [7]:

fnℓ,nu =







28n5u(nu−1)2nu−4

3(nu+1)2nu+4 nℓ = 1

25

3
√
3π

1

1−(nu/nℓ)
2
1
n3ℓ

1
n3u
g nℓ > 1

, (3.36)

where

g≈ 1−0.1728
1+(nu/nℓ)

2

[

(1− (nu/nℓ)
2)nℓ

]2/3
. (3.37)

The Einstein coefficient A (rate of the spontaneous emission):

Anu,nℓ
= 2α3E2

tr fnℓ,nu

n2ℓ
n2u

. (3.38)

Natural line-width:

Γnat = Γnu + Γnℓ
, (3.39)

where only contributions due to the radiative decay to the ground state are retained:

Γn ≈ An,1 . (3.40)

Fine structure is a sum of fine-structure splittings of the upper and lower levels:

∆Efs = ∆Enu + ∆Enℓ
, (3.41)

where each is estimated as a difference between the fine-structure corrections of the levels with the

lowest ( j = 1/2) and the highest ( j = n−1/2) total angular momentum j:

∆En = ∆En,1/2−∆En,n−1/2 , (3.42)

where

∆En, j =
Z4
coreα

2

2n3

(

1

j+1/2
− 3

4n

)

(3.43)

(see, e.g., [8]).

Doppler full width at half-maximum (FWHM, hereafter simply “width”):

wD =
√
8ln2

vth,r

c
Etr . (3.44)

Zeeman splitting is estimated in the Paschen-Back limit according to

∆Emf = 2µBB , (3.45)

where µB is the Bohr magneton.

Classical ionization field (for the upper level):

Fi =
Z3
core

16n4u
. (3.46)
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Inglis-Teller field (the field at which the adjacent nu and nu + 1 Stark manifolds start to overlap):

FIT =
Z3
core(2nu +1)

6n4u(nu +1)2
. (3.47)

Typical Debye screening (plasma screening of a Coulomb field exerted by a probe charge at the

distance of the Wigner-Seitz radius):

(1+ rs/λD,s)exp (−rs/λD,s) . (3.48)

Holtsmark field [9]:

F0,s = 2π

(

4

15

)2/3

|qs|Ns
2/3 . (3.49)

Typical micro-field frequency:

fF,s =
√

vth,s2 + vth,r2/rs . (3.50)

The Stark broadening is calculated in the quasi-contiguous (QC) approximation [10], applica-

ble to transitions between degenerate atomic levels. The method is summarized below.

The quasi-static Stark width due to micro-fields of species s is given by

wqs,s = ω̄0
1/2

3(n2u−n2ℓ)

Zcore
F0,sηpp,sηrp,s×

{

1
2

nu−nℓ = 1

1 nu−nℓ > 1
, (3.51)

where ω̄0
1/2 ≈ 1.4385, the perturber-perturber ηpp,s and radiator-perturber ηrp,s correlation correc-

tion factors are, respectively,

ηpp,s = (1+ rs/λ̄D,s)exp(−rs/λ̄D,s)

and

ηrp,s = exp(−qrqs/rsTs) .

(The 1/2 factor in eq. (3.51), not present in the original study [10], was empirically found to serve

as a rough correction for the ∆n = 1 case; we remind the reader that the QC approximation was

derived assuming ∆n≫ 1).

Static/dynamic Stark ratio:

Rs =
wqs,s

fF,sηrp,s
. (3.52)

Stark “quasistaticity” factor:

fs =
Rs

Rs +0.5
. (3.53)

The Stark width due to species s as perturbers:

wS,s = fswqs,s , (3.54)

resulting in the total Stark width

wS,tot =

[

∑
s

wS,s
3/2

]2/3

. (3.55)
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3.6 Radiation

Cyclotron losses [3] per plasma volume:

− dEc,s
dt

=
4α3q2sω2

g,sTs

3ms

Ns . (3.56)

Free-free (Bremsstrahlung) losses [3] per plasma volume:

− dEff
dt

=
8πα3

√
TeNe

3
∑
s 6=e

Nsq
2
s . (3.57)

Free-bound (recombination) losses per plasma volume:

− dEfb
dt

=
4πα3Ne

3
√
Te

∑
s 6=e

Nsq
4
s . (3.58)

The expression above is obtained using, for each heavy species s, the approximate relation [11]
dEfb,s
dt

/dEff,s
dt

≈ E∞,s

Te
, where E∞,s = q2s/2 is the bound energy of the ground state of the recombined

ion.

The power spectral density of the free-free radiation at the transition energy Etr:

− dEff(Etr)

dt
= −exp(−Etr/Te)

Te

dEff
dt

, (3.59)

and similarly for the free-bound radiation:

− dEfb(Etr)

dt
=

8πα3Ne

3T
3/2
e

∑
s 6=e

θ(Etr−E∞,s)Nsq
2
sE∞,s exp [−(Etr−E∞,s)/Te] , (3.60)

where θ(x) is the Heaviside step function (θ(x) is zero for negative x and unity for positive x).

Evidently, only recombination to the ground state is accounted for.

4 User’s guide

“Plasma Formulary Interactive” is built as a JavaScript Web application in order to provide a max-

imal cross-platform capability, independent of an underlying operating system. The graphical user

interface (GUI) is built using the Qooxdoo toolkit [12] and should be compatible with a majority of

modern browsers. The required resources are rather moderate, making the application responsive

even on low-end devices such as modern smartphones. It is available at the following address:

http://plasma-gate.weizmann.ac.il/pf/.

The main GUI consists of four tabbed panels. The first, “Parameters” panel (see figure 1)

allows for defining the parameters of the plasma model (section 2): Ne, Te, Zi, Mi, Ti, Zr, Mr, Tr,

Pr, B, and those of the atomic system of the radiator: nu and nℓ. Ni, Nr, and Zcore are automati-

cally updated using eqs. (2.5), (2.6), and (2.8), respectively. Since usually one is interested in fully

thermalized plasmas (Te = Ti = Tr), for convenience, changing Te automatically updates Ti and Tr,

while changing Ti automatically updates Tr. Therefore, if Te 6= Ti 6= Tr is required, one should first

– 8 –
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Figure 1. (Color online) The “Parameters” panel.

enter Te, followed by Ti and further followed by setting Tr. A complete set of plasma parame-

ters can be saved using “File→Save” or “File→Save As” menu entries under a desired name for

further loading.

The next, “Explorer” panel (figure 2), allows for browsing plasma entities arranged in a tree

structure according to the dimension units. The complete list is given below, alongside with refer-

ences to the corresponding expressions in parentheses.

• Dimensionless

– Coupling parameter (3.6)

– Typical Debye screening (3.48)

– Beta (3.10)

– Oscillator strength (3.36)

– Stark quasistaticity (3.53)

– Static/dynamic Stark ratio (3.52)

– Coulomb logarithm (3.26)

• Length

– Wigner-Seitz radius (3.1)

– Debye length (3.4)

– Full Debye length (3.5)

– Gyroradius (3.13)

– Distance of minimal approach (3.14)

– Inertial length (3.22)

– 9 –
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Figure 2. (Color online) The “Explorer” panel.

– De Broglie wavelength (3.15)

– Transition wavelength (3.34)

• Frequency

– Plasma frequency (3.20)

– Gyrofrequency (3.12)

– Transition frequency (3.33)

– Einstein coefficient (3.38)

– Microfield frequency (3.50)

– Relaxation rate (3.29)

• Velocity

– Thermal velocity (3.11)

– Alfvén velocity (3.23)

• Area

– Thomson cross-section (3.24)

• Mass density

– Mass density (3.2)

– Total mass density (3.3)

• Energy

– Transition energy (3.31)

– Natural linewidth (3.39)

– Fine structure (3.41)

– 10 –
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– Doppler FWHM (3.44)

– Zeeman splitting (3.45)

– Total Stark FWHM (3.55)

– Stark FWHM (3.54)

– QS Stark FWHM (3.51)

– Dynamic Stark range (3.50)

– Minimal energy distance (3.35)

– Plasmon energy (3.21)

– Fermi energy (3.16)

– Chemical potential (3.17) and (3.19)

• Pressure

– Ideal gas pressure (3.7)

– Total pressure (3.8)

– Magnetic field pressure (3.9)

• Power density

– Cyclotron losses (3.56)

– Free-free losses (3.57)

– Free-bound losses (3.58)

• Power spectral density

– Free-free spectral density (3.59)

– Free-bound spectral density (3.60)

• Electric field

– Holtsmark field (3.49)

– Classical ionization field (3.46)

– Inglis-Teller field (3.47)

– Dreicer field (3.30)

If desired, the displayed entities can be filtered either according to the species they refer to

(Electrons/Ions/Radiators), or by section they belong to (Fundamental/Waves/Collisions/Spectros-

copy/Radiation) using the “View→Show Species” and “View→Show Sections” menu entries, re-

spectively.

Selecting an entity from the list results in its value being calculated (for the plasma parameters

selected) and displayed, and the corresponding Wikipedia article (if exists) optionally shown. The

calculated value can be shown in a.u., SI, CGS, and some more widely used units, e.g., angstroms

(Å) for entities having dimension of length. While selected, the entity can be added to, or removed

from, the list of “favorites” using either the context-sensitive or menubar “Edit” pull-down menu.

The “favorite” entities are used for further comparison or plotting (see below).

The third, “Compare” panel (figure 3) serves for comparison of previously selected “favorite”

entities, where these are listed in a table by groups having the same dimension.

Finally, the “Plot” panel, shown in figure 4, allows for graphing the previously selected “fa-

vorites” (grouped by the same dimension) as a function of one of the parameters of the plasma

model: Ne, Te, Ti, Tr, Pr, and B. It is also possible to change Ti and Tr or all three Te, Ti, and

Tr simultaneously. The range of the parameter being varied, line colors, and number of points

are adjustable.

– 11 –
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Figure 3. (Color online) The “Compare” panel.

Figure 4. (Color online) The “Plot” panel.
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